Descrição
Quando tento enviar uma nota para o SEFAZ ela retorna com a mensagem de rejeição:
‘Rejeição: cEAN inválido’
Causa
Quando for emitida uma NF-e e o Código GTIN (Campo: det / prod / cEAN – ID: I03), antigo Código EAN ou Código de Barras, for preenchido apenas com zeros ou com o dígito verificador inválido será retornado a rejeição “611 – cEAN inválido”.
Exemplos:
Foi emitida uma NF-e com o Código de Barras apenas com zeros informados. Nessa situação, a NF-e será rejeitada pelo motivo 611.
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Veja regra de validação da Sefaz:
Solução
Deve-se verificar se o preenchimento do campo cEAN está adequado a regra de validação da Sefaz. Entre em contato com o suporte do seu ERP e solicite que verifiquem se as regras que são utilizadas para preencher o campo em questão atendem as especificações. É necessário avaliar duas situações que são responsáveis por essa rejeição:
- Valor para o campo cEAN preenchido apenas com zeros;
- Valor com Dígito Verificador (último valor numérico da sequência) inválido, ou seja, há um erro no cálculo deste valor, que é baseado nos outros números que compõem a sequência numérica do cEAN.
Veja abaixo um exemplo válido:
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<prod> <cProd>4059</cProd> <cEAN>00000011111115</cEAN> <xProd>Soluções</xProd> <NCM>84439939</NCM> <CFOP>5101</CFOP> <uCom>UN</uCom> <qCom>1.0000</qCom> <vUnCom>1.0000000000</vUnCom> <vProd>1.00</vProd> <cEANTrib/> <uTrib>UN</uTrib> <qTrib>1.0000</qTrib> <vUnTrib>1.0000000000</vUnTrib> <indTot>1</indTot></prod> |
Referência
- Manual de Orientação do Contribuinte – http://www.nfe.fazenda.gov.br/portal/exibirArquivo.aspx?conteudo=9hd38oni4Nc=